Hispasec•July 22, 2026•🇪🇸Translated from Spanish

Critical wp2shell Vulnerability Chain Exploited in WordPress for Unauthenticated Remote Code Execution and Webshell Deployment

A critical vulnerability chain in WordPress Core, known as wp2shell, is being actively exploited to achieve unauthenticated remote code execution and install persistent webshells. The issue has been addressed in WordPress 7.0.2, 6.9.5, and 6.8.6, and site owners are strongly advised to apply updates without delay while checking exposed servers for signs of compromise.

Administrators running recent versions of WordPress Core currently face a direct threat. The wp2shell chain allows attackers to take full control of the server without any credentials and is already being used in real-world attacks to deploy webshells and malicious plugins. The risk primarily affects installations on the 7.0.x branch before 7.0.2 and the 6.9.x branch before 6.9.5, with a fixed release also available for the 6.8 branch at version 6.8.6.

Technical Details of the Exploit Chain

The core of the attack lies in the WordPress REST API, specifically its batch processing mechanism. Attackers combine two vulnerabilities, CVE-2026-63030 and CVE-2026-60137, to move from seemingly legitimate requests to full unauthenticated remote code execution. The first flaw involves a path confusion issue in the batch processing endpoint, while the second exploits an SQL injection in WP_Query tied to the author__not_in parameter. Together these issues allow escalation from manipulated queries to arbitrary code execution on the server.

Observed indicators align with automated attack campaigns. These include widespread scanning of WordPress instances, queries to the REST API to enumerate potential administrators, and collection of usernames and email addresses. In parallel, attackers attempt local file inclusion targeting wp-config.php to extract database credentials and authentication keys.

Persistence and Post-Exploitation Activity

Once access is gained, the primary goal is establishing persistence. Attackers have been observed creating PHP webshells in paths such as wp-content/cache using random filenames. These webshells return a fake 404 response unless the expected parameter is supplied. In some cases, intruders also create fraudulent administrator accounts or install plugins that facilitate remote control.

Recommended Mitigation Steps

The immediate priority is updating to WordPress 7.0.2, 6.9.5, or 6.8.6 depending on the installed branch and verifying that automatic security updates have been applied. After patching, administrators should review access and application logs for anomalous requests to the REST API and its batch endpoints, inspect installed plugins, and remove any recent unauthorized user accounts.

It is also recommended to search for newly created PHP files in unusual locations inside wp-content, audit users with elevated privileges, and delete any unauthorized accounts. If there are indications that wp-config.php was accessed, database credentials, authentication keys, and admin panel passwords must be rotated. In confirmed compromise scenarios, the response should include containment, clean reinstallation from a trusted backup, and full rotation of all secrets to eliminate persistence.

Related articles

Habr•Vulnerabilities & Exploits

Enodia: Open-Source Go Tool Automates Service Inventory, EOL Tracking and CVE Correlation

A DevOps engineer has released enodia, a single-binary Go CLI that discovers real versions of services across large heterogeneous environments and correlates them with end-of-life calendars and vulnerability databases. The tool was built after manual Ansible-based inventories and existing solutions such as endoflife.date, nvchecker, Renovate and Uptime Kuma proved insufficient for covering both infrastructure and application services while also providing actionable lifecycle, patch and branch status. Enodia uses product-specific probes for 123 technologies including PostgreSQL, MySQL, MariaDB, Jira, Confluence, Bitbucket, VMware vCenter, ESXi, pfSense and multiple Linux distributions, falling back to a generic URL-plus-regex probe when needed. Data collection is deliberately separated from evaluation so that inventory.jsonl files can be generated inside air-gapped networks and later analysed where CVE feeds are available. The project also contributed dozens of missing products and corrected EOL dates to the endoflife.date project and integrates both NVD and Russia’s FSTEC BDU vulnerability databases. Special handling was added for MySQL/MariaDB connection-error counters, version-string masquerading, and vendor-specific update nomenclature to avoid false reports.

BoletimSec•Vulnerabilities & Exploits

Telegram Voice Call Flaw Allows Remote Code Execution on Android Devices

Security researchers disclosed a vulnerability in Telegram for Android that enables remote code execution on a victim's device simply by answering a voice call. The attacker requires only a standard account, and the flaw was present in versions 8.6.2 through 12.10.3 released between March 2022 and September 2026. Telegram addressed the issue in version 12.10.4, released at the end of September 2026. The root cause lies in improper handling of the MediaState message exchanged during calls, specifically when processing rotation values and missing video state fields, leading to out-of-bounds memory reads. The same underlying fix was deployed earlier to shared call libraries, iOS, and desktop clients, but reached Android later. Researchers confirmed the impact only on private calls running on ARM64 Android devices, with no evidence of exploitation in the wild or public CVE assignment as of October 29, 2026.

安全客•Vulnerabilities & Exploits

360 Security Cloud Opens PHP2Shell Vulnerability Self-Check Platform to Government and Enterprise Users

360 Security Cloud has launched a dedicated self-assessment platform that allows organizations to scan their PHP-based websites and systems for the PHP2Shell vulnerability. The service is now available to government agencies, large enterprises, and small-to-medium businesses. Users can apply by scanning a provided QR code to determine how many of their assets run PHP, identify affected versions, and check whether any systems have already been compromised. The platform addresses key questions about exposure: the number of PHP-powered sites and systems, the presence of vulnerable versions, and signs of prior intrusion. The announcement emphasizes that the tool helps organizations proactively assess risk without requiring external assistance. The original Chinese report was published on October 30, 2026, and the service is positioned as a practical response to ongoing PHP-related security concerns.

Habr•Vulnerabilities & Exploits

Liferay Community Edition Misconfiguration Exposes Plaintext Passwords in Government Systems via CWE-319

A detailed analysis reveals how the use of Liferay Community Edition in a closed government information system led to the transmission of user passwords in plaintext through transactional emails. The issue stemmed from default notification templates that included the [$PASSWORD$] macro, combined with unadjusted system variables pointing to localhost instead of the production domain. Despite proper OAuth 2.0 delegation and CSRF protections, the misconfigured password change workflow sent permanent credentials in clear text to user inboxes. The root cause was traced to custom portlets that incorrectly reused the New Password Notification trigger intended only for administrator-initiated resets. Remediation involves removing the password macro from email templates and updating portal-ext.properties to enforce production host settings. The case highlights how open-source enterprise platforms require thorough hardening beyond initial code audits when deployed in high-security environments.