安全客•August 17, 2026•🇨🇳Translated from Chinese

SAP Commerce Cloud CVE-2026-58231 Critical Flaw Exploited in the Wild Just Three Days After Patch

SAP Commerce Cloud has been struck by a maximum-severity vulnerability, CVE-2026-58231, rated CVSS 10.0. The flaw permits unauthenticated remote code execution and was actively exploited in the wild only three days after the vendor released patches.

Security researchers first published exploitation traffic on 14 August, catching many organizations still digesting the August patch bulletin. SAP assigned the issue its highest priority rating, HotNews, while firms such as Onapsis placed it at the top of their remediation lists for the month.

Where the flaw resides

The vulnerability affects the Data Hub Adapter component responsible for exchanging and importing data between SAP Commerce Cloud and external systems. Attackers abuse a default authentication client that possesses excessive privileges and lacks proper input validation, effectively granting a universal access token to any reachable endpoint.

No credentials or user interaction are required; a single HTTP request is sufficient to achieve arbitrary code execution and full compromise of the application and its connected components.

Why the platform is a high-value target

SAP Commerce Cloud, formerly known as SAP Hybris, serves as the online storefront and B2B transaction layer for numerous global retailers and manufacturers. It is deeply integrated with ERP, CRM, inventory, payment, and fulfillment systems, meaning a breach can expose an entire business chain.

Scanning data from Shadowserver shows more than 4,200 internet-reachable instances worldwide, concentrated in Europe and North America, underscoring the broad attack surface.

Rapid weaponization driven by automation

Security teams observed the first exploitation attempts on 14 August, three days after the 11 August patch release. Analysts attribute the speed to automated and AI-assisted reverse engineering that quickly identifies patch differences and constructs working exploits.

This compressed timeline renders traditional quarterly patching cycles obsolete and forces organizations to treat such issues as immediate emergency events.

Immediate mitigation steps

  • Upgrade to SAP Commerce Cloud 2211.55, 2211-jdk21.17 or later versions listed in security note 3771065.
  • Verify that production systems are actually running the updated releases.
  • Apply IP Filter Sets to restrict Data Hub Adapter endpoints to trusted sources only.
  • Map all backend integrations, service accounts, and data flows to understand potential blast radius before an incident occurs.

Related articles

Habr•Vulnerabilities & Exploits

sshhole: OpenSSH Authentication Bypass on musl libc Systems Without PAM

An emergency patch for OpenSSH 10.6p2 was released on November 5, 2026, to fix a critical authentication bypass vulnerability affecting Linux systems using musl libc without PAM support. The flaw allowed attackers to log into accounts with a locked password by supplying any string longer than 256 bytes. The root cause traces back to a chain of engineering decisions: musl's crypt() returning '*' on length errors instead of NULL, OpenSSH's 2016 timing attack mitigation that selected salts from real hashes, and the resulting strcmp match between error result and the shadow '*' marker. Exploitation required a specific combination of musl, OpenSSH without PAM, password authentication enabled, and an account marked with '*' in /etc/shadow, notably impacting Alpine Linux cloud images. The vulnerability was discovered by researcher Özgün Kültekin using LLM-assisted fuzzing of 17,600 authentication variants. OpenSSH 10.6p2 or equivalent distribution patches close the issue; until applied, administrators should set PasswordAuthentication no where password login is unnecessary.

BoletimSec•Vulnerabilities & Exploits

Critical Command Injection Vulnerability in SolarWinds Dameware Enables Remote System Compromise

SolarWinds disclosed CVE-2026-28336, a critical command injection flaw in its Dameware remote support tool on November 3, 2026. Rated 9.9 out of 10, the vulnerability allows an authenticated user to execute arbitrary commands on remote systems managed by the software. The issue stems from insufficient input validation when user-supplied data is passed to the operating system, enabling attackers to append malicious commands. Exploitation requires only a valid, even low-privileged, Dameware account and occurs over the network with low complexity and no user interaction. The flaw affects version 2026.3 and all prior releases, with a fix available in 2026.3.1. SolarWinds also recommends reviewing account lists and restricting network access to administrative segments. This marks the latest in a series of security issues for the vendor, following a privilege escalation fix in 2025 and patches for fifteen Serv-U vulnerabilities in July.

AntiMalware•Vulnerabilities & Exploits

GhostMap Vulnerability Forces Android Devices into Unrecoverable Boot Loops

Bitdefender researchers have identified GhostMap, a vulnerability that causes system_server to crash repeatedly when processing a specially crafted APK file. The flaw stems from inconsistent handling of ZIP archive parameters across Android system libraries, allowing a malformed resource to trigger an infinite reboot cycle. No code execution or permissions are required; the malicious APK only needs to be present on the device. The issue affects devices running Android 10 and later, with successful reproduction demonstrated on a Pixel device running Android 17 and the August 2026 security patch. Safe mode fails to interrupt the loop, and recovery often requires a factory reset that erases local data. Google initially closed the report as unreproducible before reassigning it to the appropriate team for potential future remediation.

Security NEXT•Vulnerabilities & Exploits

CISA Adds Apple CVE-2024-27834 to Known Exploited Vulnerabilities Catalog After Confirmed Exploitation

The U.S. Cybersecurity and Infrastructure Security Agency has added the Apple vulnerability CVE-2024-27834 to its Known Exploited Vulnerabilities catalog following confirmed in-the-wild exploitation. The flaw impacts multiple Apple platforms including iOS, iPadOS, macOS, Safari, tvOS, and watchOS. It is an authentication bypass issue that can be exploited for arbitrary read and write operations when an attacker already possesses initial access rights. The vulnerability was discovered and patched in 2024, yet exploitation activity has now prompted federal action. NIST rates the issue at CVSS 5.5 Medium. U.S. federal agencies are required to apply mitigations by November 18.